SortParameters Method


Family Manager Sort Parameters Method

Sorts the family parameters according to the desired sort order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SortParameters(
	ParametersOrder order
)

Parameters

order ParametersOrder
The desired sort order.
Exceptions
Exception Condition
InvalidOperationException Thrown when this family is a Rebar Shape family which doesn't support parameters reorder.
Remarks

The sort only affects visible parameters within the same parameter group.

Parameters that belong to different groups will remain separated, and the groups' order will not be affected.

The sort is a one-time operation and when new parameters are added they will not be automatically sorted.

Example
private void DisplayParametersInAscendingOrder(Document familyDoc)
{
    FamilyManager familyManager = familyDoc.FamilyManager;
    familyManager.SortParameters(ParametersOrder.Ascending);
}
See Also