GetSketchGalleryOptions Method


UIDocument Get Sketch Gallery Options Method

Gets the valid sketch gallery options of a family symbol.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<SketchGalleryOptions> GetSketchGalleryOptions(
	FamilySymbol familySymbol
)

Parameters

familySymbol FamilySymbol
The family symbol.

Return Value

IList SketchGalleryOptions
The valid list of SketchGalleryOptions.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also