RotateElement Method


Element Transform Utils Rotate Element Method

Rotates an element about the given axis and angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void RotateElement(
	Document document,
	ElementId elementToRotate,
	Line axis,
	double angle
)

Parameters

document Document
The document that owns the elements.
elementToRotate ElementId
The element to rotate.
axis Line
The axis of rotation.
angle Double
The angle of rotation in radians.
Exceptions
Exception Condition
ArgumentException The element elementToRotate does not exist in the document
ArgumentNullException A non-optional argument was null
Example
public void RotateColumn(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    XYZ point1 = new XYZ(10, 20, 0);
    XYZ point2 = new XYZ(10, 20, 30);
    Line axis = Line.CreateBound(point1, point2);
    ElementTransformUtils.RotateElement(document, element.Id, axis, Math.PI / 3.0);
}
See Also