Element |
Rotates an element about the given axis and angle.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public static void RotateElement(
Document document,
ElementId elementToRotate,
Line axis,
double angle
)
Parameters

Exception | Condition |
---|---|
ArgumentException | The element elementToRotate does not exist in the document |
ArgumentNullException | A non-optional argument was null |