ExternalResourceType Class


External Resource Type Class

A type class used to distinguish between different kinds of external resource.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB GuidEnum
Autodesk.Revit.DB ExternalResourceType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalResourceType : GuidEnum

The ExternalResourceType type exposes the following members.

Constructors
Name Description
Public method ExternalResourceType Creates a new ExternalResourceType instance.
Top
Properties
Name Description
Public property Guid The Guid of GUID-based enum object.
(Inherited from GuidEnum )
Top
Methods
Name Description
Public method Equals Compares two Guid-based enum object based on their concrete class and GUID value.
(Inherited from GuidEnum )
Public method GetHashCode Generates a hash code for this Guid-based enum object.
(Inherited from GuidEnum )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Operators
Name Description
Public operator Static member Equality(ExternalResourceType, ExternalResourceType) Compares two ExternalResourceType instances.
Public operator Static member Inequality(ExternalResourceType, ExternalResourceType) Compares two ExternalResourceType instances.
Top
Remarks
Revit elements can consume multiple types of external resource data, provided by one or more external servers. Conversely, external servers can support one, or more than one, type of external resource.
See Also