External |
A type class used to distinguish between different kinds of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExternalResourceType type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExternalResourceType | Creates a new ExternalResourceType instance. |


Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() ![]() | Equality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances. |
![]() ![]() | Inequality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances. |

Revit elements can consume multiple types of external resource data, provided by one or more external servers. Conversely, external servers can support one, or more than one, type of external resource.