External |
A type class used to distinguish between different kinds of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExternalResourceType type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExternalResourceType | Creates a new ExternalResourceType instance. |


Name | Description | |
---|---|---|
![]() | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum ) |
![]() | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Name | Description | |
---|---|---|
![]() ![]() | Equality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances. |
![]() ![]() | Inequality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances. |

Revit elements can consume multiple types of external resource data, provided by one or more external servers. Conversely, external servers can support one, or more than one, type of external resource.