ParameterFilterUtilities Class


Parameter Filter Utilities Class

Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ParameterFilterUtilities

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ParameterFilterUtilities

The ParameterFilterUtilities type exposes the following members.

Methods
Name Description
Public method Static member GetAllFilterableCategories Returns the set of categories that may be used in a ParameterFilterElement.
Public method Static member GetFilterableParametersInCommon Returns the filterable parameters common to the given categories.
Public method Static member GetInapplicableParameters Returns the parameters that are not among the set of filterable parameters common to the given categories.
Public method Static member IsParameterApplicable Used to determine whether the element supports the given parameter.
Public method Static member RemoveUnfilterableCategories Removes from the given set the categories that are not filterable.
Top
See Also