Parameter |
Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.

System Object
Autodesk.Revit.DB ParameterFilterUtilities
Autodesk.Revit.DB ParameterFilterUtilities
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ParameterFilterUtilities type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement. |
![]() ![]() | GetFilterableParametersInCommon | |
![]() ![]() | GetInapplicableParameters | |
![]() ![]() | IsParameterApplicable | Used to determine whether the element supports the given parameter. |
![]() ![]() | RemoveUnfilterableCategories |