Form Move Profile Method Move a profile of the form, specified by a reference, and an offset vector. Namespace: Autodesk.Revit.DB Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0) Syntax C# VB C++ F# public void MoveProfile( int profileIndex, XYZ offset ) Public Sub MoveProfile ( profileIndex As Integer, offset As XYZ ) public: void MoveProfile( int profileIndex, XYZ^ offset ) member MoveProfile : profileIndex : int * offset : XYZ -> unit Parameters profileIndex Int32 Index to specify the profile. offset XYZ The vector by which the element is to be moved. Example C# VB C++ F# public void MoveForm(Form form) { int profileCount = form.ProfileCount; if (form.ProfileCount > 0) { int profileIndex = 0; // modify the first form only if (form.CanManipulateProfile(profileIndex)) { XYZ offset = new XYZ(-25, 0, 0); form.MoveProfile(profileIndex, offset); } } } Public Sub MoveForm(form As Form) Dim profileCount As Integer = form.ProfileCount If form.ProfileCount > 0 Then Dim profileIndex As Integer = 0 ' modify the first form only If form.CanManipulateProfile(profileIndex) Then Dim offset As New XYZ(-25, 0, 0) form.MoveProfile(profileIndex, offset) End If End If End Sub No code example is currently available or this language may not be supported. No code example is currently available or this language may not be supported. See Also Reference Form Class Autodesk.Revit.DB Namespace
Form Move Profile Method Move a profile of the form, specified by a reference, and an offset vector. Namespace: Autodesk.Revit.DB Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0) Syntax C# VB C++ F# public void MoveProfile( int profileIndex, XYZ offset ) Public Sub MoveProfile ( profileIndex As Integer, offset As XYZ ) public: void MoveProfile( int profileIndex, XYZ^ offset ) member MoveProfile : profileIndex : int * offset : XYZ -> unit Parameters profileIndex Int32 Index to specify the profile. offset XYZ The vector by which the element is to be moved. Example C# VB C++ F# public void MoveForm(Form form) { int profileCount = form.ProfileCount; if (form.ProfileCount > 0) { int profileIndex = 0; // modify the first form only if (form.CanManipulateProfile(profileIndex)) { XYZ offset = new XYZ(-25, 0, 0); form.MoveProfile(profileIndex, offset); } } } Public Sub MoveForm(form As Form) Dim profileCount As Integer = form.ProfileCount If form.ProfileCount > 0 Then Dim profileIndex As Integer = 0 ' modify the first form only If form.CanManipulateProfile(profileIndex) Then Dim offset As New XYZ(-25, 0, 0) form.MoveProfile(profileIndex, offset) End If End If End Sub No code example is currently available or this language may not be supported. No code example is currently available or this language may not be supported. See Also Reference Form Class Autodesk.Revit.DB Namespace