Content |
This class represents a generic content node in a model-exporting process.

System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ContentNode
Autodesk.Revit.DB LightNode
Autodesk.Revit.DB RPCNode
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ContentNode
Autodesk.Revit.DB LightNode
Autodesk.Revit.DB RPCNode
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ContentNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode ) |
![]() | NodeName | A readable name of the output node. (Inherited from RenderNode ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetTransform | A transformation matrix associated with the node. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Members of this class implement properties and methods common to all content classes, such as RPC and Light nodes. Attributes of a content note can be accessed via an Asset object.