ContentNode Class


Content Node Class

This class represents a generic content node in a model-exporting process.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ContentNode : RenderNode

The ContentNode type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method GetAsset Returns an an instance of an Asset object, which contains definitions of the content node.
Public method GetTransform A transformation matrix associated with the node.
Top
Remarks
Members of this class implement properties and methods common to all content classes, such as RPC and Light nodes. Attributes of a content note can be accessed via an Asset object.
See Also