Asset Class


Asset Class

Represents a connected property of material.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Asset : AssetProperties

The Asset type exposes the following members.

Properties
Name Description
Public property AssetType The type of RenderingAsset
Public property IsReadOnly Identifies if the object is read-only or modifiable. If true, the object may not be modified. If false, the object's contents may be modified.
(Inherited from AssetProperty )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AssetProperty )
Public property Item
(Inherited from AssetProperties )
Public property LibraryName Library name
Public property Name Get the name of the AssetProperty
(Inherited from AssetProperty )
Public property NumberOfConnectedProperties The number of currently connected properties.
(Inherited from AssetProperty )
Public property Size The number of the AssetProperty(s) in the object.
(Inherited from AssetProperties )
Public property Title Asset title
Public property Type Returns the type of the AssetProperty
(Inherited from AssetProperty )
Top
Methods
Name Description
Public method AddConnectedAsset Adds a new connected asset attached to this asset property, if it allows it.
(Inherited from AssetProperty )
Public method Code example AddCopyAsConnectedAsset Makes a copy of the asset and connects it to this property.
(Inherited from AssetProperty )
Public method Dispose
(Inherited from AssetProperty )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method FindByName Gets the property with the given name.
(Inherited from AssetProperties )
Public method Get Gets the property at the given index.
(Inherited from AssetProperties )
Public method GetAllConnectedProperties Gets the list of the connected properties. Connected properties are the detachable properties of an AssetProperty. e.g. diffuse property can have texture as its connected property. It can also detach texture on runtime.
(Inherited from AssetProperty )
Public method GetConnectedProperty Gets one connected property with specified index.
(Inherited from AssetProperty )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Code example GetSingleConnectedAsset Gets the single connected asset attached to this asset property, if it exists.
(Inherited from AssetProperty )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsEditable Check if property can be edited.
(Inherited from AssetProperty )
Public method IsValidIndex Returns true if the provided index is valid.
(Inherited from AssetProperties )
Public method IsValidSchemaIdentifier Check that schema name is valid
(Inherited from AssetProperty )
Public method RemoveConnectedAsset Removes the connected asset attached to this asset property if any.
(Inherited from AssetProperty )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Example
public void ReadAsset(Asset asset)
{
   // Get the asset name, type and library name.
   AssetType type = asset.AssetType;
   string name = asset.Name;
   string libraryName = asset.LibraryName;

   // travel the asset properties in the asset.
   for (int idx = 0; idx < asset.Size; idx++)
   {
      AssetProperty prop = asset.Get(idx);
      ReadAssetProperty(prop);
   }
}

public void ReadAssetProperty(AssetProperty prop)
{
   switch (prop.Type)
   {
      // Retrieve the value from simple type property is easy.
      // for example, retrieve bool property value.
      case AssetPropertyType.Boolean:
         AssetPropertyBoolean boolProp = prop as AssetPropertyBoolean;
         bool propValue = boolProp.Value;
         break;

      // When you retrieve the value from the data array property,
      // you may need to get which value the property stands for.
      // for example, the APT_Double44 may be a transform data.
      case AssetPropertyType.Double44:
         AssetPropertyDoubleArray4d transformProp = prop as AssetPropertyDoubleArray4d;
         IList<double> tranformValue = transformProp.GetValueAsDoubles();
         break;

      // The APT_List contains a list of sub asset properties with same type.
      case AssetPropertyType.List:
         AssetPropertyList propList = prop as AssetPropertyList;
         IList<AssetProperty> subProps = propList.GetValue();
         if (subProps.Count == 0)
            break;
         switch (subProps[0].Type)
         {
            case AssetPropertyType.Integer:
               foreach (AssetProperty subProp in subProps)
               {
                  AssetPropertyInteger intProp = subProp as AssetPropertyInteger;
                  int intValue = intProp.Value;
               }
               break;
         }
         break;

      case AssetPropertyType.Asset:
         Asset propAsset = prop as Asset;
         ReadAsset(propAsset);
         break;
      default:
         break;
   }

   // Get the connected properties.
   // please notice that the information of many texture stores here.
   if (prop.NumberOfConnectedProperties == 0)
      return;
   foreach (AssetProperty connectedProp in prop.GetAllConnectedProperties())
   {
      // Note: Usually, the connected property is an Asset.
      ReadAssetProperty(connectedProp);
   }
}
See Also