Topography |
Note: This API is now obsolete.
Creates a new topography surface element from facets and adds it to the document.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

[ObsoleteAttribute("This method is deprecated in Revit 2024 with the introduction of the new Toposolid elements. It is recommended that Toposolid elements should be used in place of TopographySurface elements.")]
public static TopographySurface Create(
Document document,
IList<XYZ> points,
IList<PolymeshFacet> facets
)
Parameters
- document Document
- The document to be modified.
- points IList XYZ
- A collection of points. The points represent an enclosed area in the XY plane.
- facets IList PolymeshFacet
- Triangle facets composing a polygon mesh. Every facet contains 3 integers representing vertex indices.
Return Value
TopographySurfaceThe new topography surface.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- There are invalid facets. Facets with more than two points with same x, y are not allowed. -or- There is(are) reference gap(s) between input arguments: points and facets. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

The document will be regenerated during the creation of this topography surface element. The topography surface created by facet cannot modify its triangle points and facets.