Area |
Creates a new custom area load within the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static AreaLoad Create(
Document document,
ElementId hostElemId,
IList<CurveLoop> loops,
IList<XYZ> forceVectors,
IList<int> refPointCurveIndexes,
IList<int> refPointCurveEnds,
AreaLoadType symbol
)
Parameters
- document Document
- Document to which new area load will be added.
- hostElemId ElementId
- The analytical surface host element id for the area Load.
- loops IList CurveLoop
- The loops that define geometry of the area load. The curve loop collection should contains a closed loops consisting of lines.
- forceVectors IList XYZ
- The array of force vectors applied to the maximum three reference point of the area load.
- refPointCurveIndexes IList Int32
- The array of maximum three curve indexes on which reference points should be placed on.
- refPointCurveEnds IList Int32
- The array of maximum three curve ends indicating where reference points should be placed on. The array can have only 0 or 1 values, which means 0 - curve start point, 1 - curve end point.
- symbol AreaLoadType
- The symbol of the AreaLoad. Set to use default type.
Return Value
AreaLoadIf successful, returns an object of the newly created AreaLoad. is returned if the operation fails.

Exception | Condition |
---|---|
ArgumentException | hostElemId is not permitted for this type of load. -or- One of the following requirements is not satisfied : - curve loops loops are not planar - curve loops loops are self-intersecting - curve loops loops contains zero length curves -or- Thrown when force vector is equal zero. |
ArgumentNullException | A non-optional argument was null |
ArgumentsInconsistentException | Thrown if the host element id is a Curved Panel. |
InvalidOperationException | Thrown if type could not be set for newly created area load. |