ElementPhaseStatusFilter Constructor (ElementId, ICollection(ElementOnPhaseStatus))


Element Phase Status Filter(Element Id, ICollection Element On Phase Status ) Constructor

Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementPhaseStatusFilter(
	ElementId phaseId,
	ICollection<ElementOnPhaseStatus> phaseStatuses
)

Parameters

phaseId ElementId
Id of the phase.
phaseStatuses ICollection ElementOnPhaseStatus
Target statuses.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also