Structural |
Creates a new instance of a Structural Connection Handler, which is defined by the elements to connect and the additional points.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static StructuralConnectionHandler Create(
Document document,
IList<ElementId> idsToConnect,
ElementId typeId,
IList<ConnectionInputPoint> additionalInputPoints
)
Parameters
- document Document
- The Revit document.
- idsToConnect IList ElementId
- List of element ids of connected elements.
- typeId ElementId
- The type of Structural Connection Handler.
- additionalInputPoints IList ConnectionInputPoint
- The array of points that help define the connection.
Return Value
StructuralConnectionHandlerThe newly created connection.

Exception | Condition |
---|---|
ArgumentException | It verifies that we have at least one element id in the list. -or- The type typeId is not a valid StructuralConnectionHandlerType. -or- Missing detailed structural connection service implementation. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

Elements should be of the following structural categories: framings (OST_StructuralFraming), columns (OST_StructuralColumns), walls (OST_Walls), floors (OST_Floors) or foundations (OST_StructuralFoundations). The first of given elements is set as primary one. The placement of the connection takes into account the additional definition points.