Create Method (Document, IList(ElementId), ElectricalSystemType)


Electrical System Create(Document, IList Element Id , Electrical System Type) Method

Creates a new MEP Electrical System element from a set of electrical components.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElectricalSystem Create(
	Document document,
	IList<ElementId> electComponents,
	ElectricalSystemType elecSysType
)

Parameters

document Document
The Document.
electComponents IList ElementId
The electrical components in this system.
elecSysType ElectricalSystemType
The System Type of electrical system.

Return Value

ElectricalSystem
If successful a new MEP Electrical System element within the project, otherwise .
Exceptions
Exception Condition
ArgumentException There should be at least one component that can create the specified circuit type
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also