MEPFamily |
MEP family connector information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MEPFamilyConnectorInfo type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsPrimary | True if this is the primary connector. (Inherited from MEPConnectorInfo ) |
![]() | IsSecondary | True if this is the secondary connector. (Inherited from MEPConnectorInfo ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from MEPConnectorInfo ) |
![]() | LinkedConnector | The linked connector or if there is no linked connector (Inherited from MEPConnectorInfo ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from MEPConnectorInfo ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAssociateFamilyParameterId | Gets the associate family parameter id of the specified connector parameter id. |
![]() | GetConnectorParameterValue | Gets the parameter value of the specified connector parameter id. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |