MEPFamilyConnectorInfo Class


MEPFamily Connector Info Class

MEP family connector information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB MEPConnectorInfo
Autodesk.Revit.DB MEPFamilyConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPFamilyConnectorInfo : MEPConnectorInfo

The MEPFamilyConnectorInfo type exposes the following members.

Properties
Name Description
Public property IsPrimary True if this is the primary connector.
(Inherited from MEPConnectorInfo )
Public property IsSecondary True if this is the secondary connector.
(Inherited from MEPConnectorInfo )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MEPConnectorInfo )
Public property LinkedConnector The linked connector or if there is no linked connector
(Inherited from MEPConnectorInfo )
Top
Methods
Name Description
Public method Dispose
(Inherited from MEPConnectorInfo )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAssociateFamilyParameterId Gets the associate family parameter id of the specified connector parameter id.
Public method GetConnectorParameterValue Gets the parameter value of the specified connector parameter id.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also