ElementArray Class


Element Array Class

An array that contains element objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB ElementArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementArray : APIObject, 
	IEnumerable

The ElementArray type exposes the following members.

Constructors
Name Description
Public method ElementArray Initializes a new instance of the ElementArray class
Top
Properties
Name Description
Public property IsEmpty Test to see if the array is empty.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Item Gets or sets an element at a specified index within the array.
Public property Size Returns the number of elements that are in the array.
Top
Methods
Name Description
Public method Append Add the element to the end of the array.
Public method Clear Removes every element from the array, rendering it empty.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method ForwardIterator Retrieve a forward moving iterator to the array.
Public method GetEnumerator Retrieve a forward moving iterator to the array.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Insert Insert the specified element into the array.
Public method ReverseIterator Retrieve a backward moving iterator to the array.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also