BuiltInFailures.ConnectorFailures Class


Built In Failures Connector Failures Class

Failures about Connector.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures ConnectorFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ConnectorFailures

The BuiltInFailures ConnectorFailures type exposes the following members.

Properties
Name Description
Public property Static member AirTerminalCenterNotAligned The center of the Air Terminal doesn't align at (0,0,0): align the Air Terminal Center to the Origin Defining Reference Planes could help to solve the problem.
Public property Static member AllElementsRemovedFromCircuitGroup [System] is empty and will be deleted.
Public property Static member DisconnectedElements Elements are disconnected!
Public property Static member ElementAssignedToDefaultSystem At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
Public property Static member ElementHasMultipleConnectors Revit found one or more elements with multiple connectors. Select each element and then select the connectors to use for the analytical connection.
Public property Static member ElementsAreDisconnected Elements need to be disconnected.
Public property Static member ElementsConnectedToParent You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.
Public property Static member ElementsNeedToBeDisconnected Elements need to be disconnected.
Public property Static member ExistsForSelectedElement Connections already exists for selected element.
Public property Static member FittingMustBeOnDuct The [Tap] must be attached to duct.
Public property Static member FittingMustBeOnDuctWarn The [Tap] must be attached to duct.
Public property Static member FittingMustBeOnPipe The [Tap] must be attached to pipe.
Public property Static member FittingMustBeOnPipeWarn The [Tap] must be attached to pipe.
Public property Static member InvalidConnectionRef The selected fitting has invalid connections and must be deleted to continue.
Public property Static member InvalidConnector The connector is invalid, the size cannot be determined from the connector.
Public property Static member InvalidLoadClassificationValue The load classification parameter cannot be empty. Please select a valid load classification element for the connector parameter and the associated family parameter.
Public property Static member InvalidPowerFactorValue The value for Power Factor must be between 0 and 1.
Public property Static member JointGenderMismatch The element has a connector with a fitting joint gender mismatch
Public property Static member JointShapeMismatch The element has a connector with a fitting joint shape mismatch
Public property Static member JointSizeMismatch The element has a connector with a fitting joint size mismatch
Public property Static member JointTypeMismatch The element has a connector with a fitting joint type mismatch
Public property Static member LayoutConnector [Unassigned System Type] on Connector [Index Number].
Public property Static member MismatchNoAvailableConnector Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
Public property Static member MultipleNetwork Elements in [System Name] are not connected in a single physical network due to one or both of the following:\n- There are disconnects in the system's physical network.\n- Elements in the system are connected to more than one physical network.
Public property Static member NetworkValidityError The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
Public property Static member NetworkValidityErrorWasDisconnected The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
Public property Static member NoLossDefined No Loss Defined
Public property Static member NoSupportKCoefficientTable "K Coefficient from table" is not supported on connector for the element
Public property Static member NotAllowedToModifyGroupElementsError Connection to a group failed. Modification of elements within a group is not allowed.
Public property Static member NotAllowedToModifyGroupElementsWarning Connection to a group failed. Modification of elements within a group is not allowed.
Public property Static member OpenConnector The element has an open connector
Public property Static member RbsNetworkValidityError The family is connected in a network and can no longer keep the connectivity.
Public property Static member RemoveConnectorLinksWarn The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
Public property Static member RemoveConnectorLinkWarn The link between connector [Index] and connector [Index] is removed.
Public property Static member ShapesNotMatch Shapes do not match. A connection could not be made.
Public property Static member SizingCalculationFlowOnlyWarn Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.
Public property Static member SizingCalculationNoneWarn Some elements are not sized because the system calculation level is none or performance. You may change the system calculation level to size them again.
Public property Static member SizingFailed Sizing failed.
Public property Static member UnconnectedCircuit The element has an unconnected circuit on its connector
Public property Static member UnconnectedDevice Device has an unconnected [Type Name] connector (index = [Index Number]).
Public property Static member UndefinedConnector Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]
Top
See Also