Tessellated |
Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The TessellatedFace type exposes the following members.

Name | Description | |
---|---|---|
![]() | TessellatedFace(IList XYZ , ElementId) | Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible. |
![]() | TessellatedFace(IList IList XYZ , ElementId) | Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MaterialId | Material of the face. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the TessellatedFace |
![]() | GetBoundaryLoops | Get loops bounding the face. |