TessellatedFace Class


Tessellated Face Class

Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TessellatedFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TessellatedFace : IDisposable

The TessellatedFace type exposes the following members.

Constructors
Name Description
Public method TessellatedFace(IList XYZ , ElementId) Initializes a new instance of the TessellatedFace class
Public method TessellatedFace(IList IList XYZ , ElementId) Initializes a new instance of the TessellatedFace class
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MaterialId Material of the face.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the TessellatedFace
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetBoundaryLoops Get loops bounding the face.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also