RoutingCondition Class


Routing Condition Class

RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RoutingCondition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RoutingCondition : IDisposable

The RoutingCondition type exposes the following members.

Constructors
Name Description
Public method RoutingCondition Creates a new RoutingCondition.
Top
Properties
Name Description
Public property Diameter The diameter of the segment or fitting specified for the routing condition.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RoutingCondition
Top
See Also