Routing |
RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RoutingCondition type exposes the following members.

Name | Description | |
---|---|---|
![]() | RoutingCondition | Creates a new RoutingCondition. |

Name | Description | |
---|---|---|
![]() | Diameter | The diameter of the segment or fitting specified for the routing condition. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RoutingCondition |