HasValueFilterRule Class


Has Value Filter Rule Class

Tests whether an element's parameter has a value.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class HasValueFilterRule : ParameterValuePresenceRule

The HasValueFilterRule type exposes the following members.

Constructors
Name Description
Public method HasValueFilterRule constructs an instance of HasValueFilterRule.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule )
Public property Parameter The parameter which will be evaluated to pass this rule.
(Inherited from ParameterValuePresenceRule )
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterRule )
Public method ElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also