Has |
Tests whether an element's parameter has a value.

System Object
Autodesk.Revit.DB FilterRule
Autodesk.Revit.DB ParameterValuePresenceRule
Autodesk.Revit.DB HasValueFilterRule
Autodesk.Revit.DB FilterRule
Autodesk.Revit.DB ParameterValuePresenceRule
Autodesk.Revit.DB HasValueFilterRule
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The HasValueFilterRule type exposes the following members.

Name | Description | |
---|---|---|
![]() | HasValueFilterRule | constructs an instance of HasValueFilterRule. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule ) |
![]() | Parameter | The parameter which will be evaluated to pass this rule. (Inherited from ParameterValuePresenceRule ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from FilterRule ) |
![]() | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |