LinkElementId Class


Link Element Id Class

LinkElementId represents an element in a linked document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LinkElementId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LinkElementId

The LinkElementId type exposes the following members.

Constructors
Name Description
Public method LinkElementId(ElementId) Creates a new LinkElementId representing an element in the host document.
Public method LinkElementId(ElementId, ElementId) Creates a new LinkElementId representing an element in a linked document.
Top
Properties
Name Description
Public property HostElementId The id of the element in the host, or invalidElementId if there is a link.
Public property LinkedElementId The id of the element in the link, or invalidElementId if no link.
Public property LinkInstanceId The id of the link, or invalidElementId if no link.
Top
Methods
Name Description
Public method Equals Determines whether the specified Object is equal to the current Object .
(Overrides Object Equals(Object) )
Top
Operators
Name Description
Public operator Static member Equality(LinkElementId, LinkElementId) Determines whether these two LinkElementIds are the same.
Public operator Static member Inequality(LinkElementId, LinkElementId) Determines whether these two LinkElementIds are different.
Top
Remarks
The id contains two element ids:
  1. The id of the linked model element in host document.
  2. The id of the element in the linked model document.
See Also