Link |
LinkElementId represents an element in a linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LinkElementId type exposes the following members.

Name | Description | |
---|---|---|
![]() | LinkElementId(ElementId) | Creates a new LinkElementId representing an element in the host document. |
![]() | LinkElementId(ElementId, ElementId) | Creates a new LinkElementId representing an element in a linked document. |

Name | Description | |
---|---|---|
![]() | HostElementId | The id of the element in the host, or invalidElementId if there is a link. |
![]() | LinkedElementId | The id of the element in the link, or invalidElementId if no link. |
![]() | LinkInstanceId | The id of the link, or invalidElementId if no link. |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Overrides Object Equals(Object) ) |

Name | Description | |
---|---|---|
![]() ![]() | Equality(LinkElementId, LinkElementId) | Determines whether these two LinkElementIds are the same. |
![]() ![]() | Inequality(LinkElementId, LinkElementId) | Determines whether these two LinkElementIds are different. |

The id contains two element ids:
- The id of the linked model element in host document.
- The id of the element in the linked model document.