Create Method (Document, ElementId, IList(CurveLoop), XYZ, AreaLoadType)


Area Load Create(Document, Element Id, IList Curve Loop , XYZ, Area Load Type) Method

Creates a new custom area load within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static AreaLoad Create(
	Document document,
	ElementId hostElemId,
	IList<CurveLoop> loops,
	XYZ forceVector,
	AreaLoadType symbol
)

Parameters

document Document
Document to which new area load will be added.
hostElemId ElementId
The analytical surface host element id for the area Load.
loops IList CurveLoop
The loops that define geometry of the area load. The curve loop collection should contains a closed loops consisting of lines.
forceVector XYZ
The force vector applied to the 1st reference point of the area load.
symbol AreaLoadType
The symbol of the AreaLoad. Set to use default type.

Return Value

AreaLoad
If successful, returns an object of the newly created AreaLoad. is returned if the operation fails.
Exceptions
Exception Condition
ArgumentException hostElemId is not permitted for this type of load. -or- One of the following requirements is not satisfied : - curve loops loops are not planar - curve loops loops are self-intersecting - curve loops loops contains zero length curves
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException Thrown if the host element id is a Curved Panel.
InvalidOperationException Thrown if type could not be set for newly created area load.
See Also