Filtered |
Returns an element iterator to the elements passing the filters.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
FilteredElementIterator
Exception | Condition |
---|---|
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter. |

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

FilteredElementCollector collector = new FilteredElementCollector(document);
// Apply a filter to get all pipes in the document
collector.OfClass(typeof(Autodesk.Revit.DB.Plumbing.Pipe));
// Get results as an element iterator and look for a pipe with
// a specific flow state
FilteredElementIterator elemItr = collector.GetElementIterator();
elemItr.Reset();
while (elemItr.MoveNext())
{
Pipe pipe = elemItr.Current as Pipe;
if (pipe.FlowState == PipeFlowState.LaminarState)
{
TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.");
break;
}
}