GetElementIterator Method


Filtered Element Collector Get Element Iterator Method

Returns an element iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public FilteredElementIterator GetElementIterator()

Return Value

FilteredElementIterator
Exceptions
Exception Condition
InvalidOperationException The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.
See Also