MEPSystem Remove(ICollection Element |
Remove elements from system.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- elementIds ICollection ElementId
- The elements to be removed from the system.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument elements is , or any element in that collection is . |
ArgumentException | Thrown when some of the elements can't be removed, or when trying to remove all elements from the system. The element which connect to the base equipment can't be removed, |
InvalidOperationException | Thrown when the operation failed. |

It is forbidden to remove all terminal elements from system. Terminal elements will be removed from the system automatically after removing this system from document.