GetShiftOption Method


Rebar Splice Type Utils Get Shift Option Method

Identifies the way bars are shifted in the splice relation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RebarSpliceShiftOption GetShiftOption(
	Document document,
	ElementId rebarSpliceTypeId
)

Parameters

document Document
The document.
rebarSpliceTypeId ElementId
The Rebar Splice Type id.

Return Value

RebarSpliceShiftOption
Returns the way bars are shifted in the splice relation.
Exceptions
Exception Condition
ArgumentException The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
ArgumentNullException A non-optional argument was null
See Also