Rebar |
Identifies the way bars are shifted in the splice relation.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static RebarSpliceShiftOption GetShiftOption(
Document document,
ElementId rebarSpliceTypeId
)
Parameters
Return Value
RebarSpliceShiftOptionReturns the way bars are shifted in the splice relation.

Exception | Condition |
---|---|
ArgumentException | The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category. |
ArgumentNullException | A non-optional argument was null |