DuctFittingAndAccessoryPressureDropUIData Class


Duct Fitting And Accessory Pressure Drop UIData Class

The input and output data used by external UI servers for storing UI settings.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI.Mechanical DuctFittingAndAccessoryPressureDropUIData

Namespace: Autodesk.Revit.UI.Mechanical
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DuctFittingAndAccessoryPressureDropUIData : IDisposable

The DuctFittingAndAccessoryPressureDropUIData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DuctFittingAndAccessoryPressureDropUIData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method GetUIDataItems Gets all UI data items stored in the UI data.
Public method GetUnits Gets units.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also