ApplicationEntryPoint Class


Application Entry Point Class

For Revit Macros use only.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI UIApplication
Autodesk.Revit.UI.Macros ApplicationEntryPoint

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class ApplicationEntryPoint : UIApplication, 
	IEntryPoint

The ApplicationEntryPoint type exposes the following members.

Constructors
Name Description
Public method ApplicationEntryPoint Initializes a new instance of the ApplicationEntryPoint class
Top
Properties
Name Description
Public property AddinFolder The full path to the Revit Macros module.
Top
Methods
Name Description
Public method CreateRibbonPanel(String)
(Overrides UIApplication CreateRibbonPanel(String) )
Public method CreateRibbonPanel(String, String)
(Overrides UIApplication CreateRibbonPanel(String, String) )
Public method CreateRibbonPanel(Tab, String)
(Overrides UIApplication CreateRibbonPanel(Tab, String) )
Public method CreateRibbonTab
(Overrides UIApplication CreateRibbonTab(String) )
Public method FinishInitializationEO For Revit Macros internal use only.
Public method GetRibbonPanels
(Overrides UIApplication GetRibbonPanels )
Public method GetRibbonPanels(String)
(Overrides UIApplication GetRibbonPanels(String) )
Public method GetRibbonPanels(Tab)
(Overrides UIApplication GetRibbonPanels(Tab) )
Public method Initialize For Revit Macros internal use only.
Public method OnShutdownEO For Revit Macros internal use only.
Top
Events
Name Description
Top
See Also