ApplicationEntryPoint Class


Application Entry Point Class

For Revit Macros use only.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI UIApplication
Autodesk.Revit.UI.Macros ApplicationEntryPoint

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class ApplicationEntryPoint : UIApplication, 
	IEntryPoint

The ApplicationEntryPoint type exposes the following members.

Constructors
Name Description
Public method ApplicationEntryPoint Initializes a new instance of the ApplicationEntryPoint class
Top
Properties
Name Description
Public property ActiveAddInId Get current active external application or external command id.
(Inherited from UIApplication )
Public property ActiveUIDocument Provides access to an object that represents the currently active project.
(Inherited from UIApplication )
Public property AddinFolder The full path to the Revit Macros module.
Public property Application Returns the database level Application represented by this UI level Application.
(Inherited from UIApplication )
Public property DrawingAreaExtents Get the rectangle that represents the screen pixel coordinates of drawing area.
(Inherited from UIApplication )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from UIApplication )
Public property IsViewerModeActive Determines if Revit session is in Viewer mode.
(Inherited from UIApplication )
Public property LoadedApplications Returns an array of successfully loaded external applications.
(Inherited from UIApplication )
Public property MainWindowExtents Get the rectangle that represents the screen pixel coordinates of the Revit main window.
(Inherited from UIApplication )
Public property MainWindowHandle Get the handle of the Revit main window.
(Inherited from UIApplication )
Public property ProductIsRS Identifies if the current Revit product has an RS designation. Most add-ins will not need to use this information.
(Inherited from UIApplication )
Top
Methods
Name Description
Public method CanPostCommand Identifies if the given command can be posted, using PostCommand(RevitCommandId) .
(Inherited from UIApplication )
Public method CreateAddInCommandBinding Creates a new AddInCommandBinding.
(Inherited from UIApplication )
Public method CreateRibbonPanel(String)
(Overrides UIApplication CreateRibbonPanel(String) )
Public method CreateRibbonPanel(String, String)
(Overrides UIApplication CreateRibbonPanel(String, String) )
Public method CreateRibbonPanel(Tab, String)
(Overrides UIApplication CreateRibbonPanel(Tab, String) )
Public method CreateRibbonTab
(Overrides UIApplication CreateRibbonTab(String) )
Public method Dispose
(Inherited from UIApplication )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method FinishInitializationEO For Revit Macros internal use only.
Public method GetDockablePane Gets a DockablePane object by its ID.
(Inherited from UIApplication )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetRibbonPanels
(Overrides UIApplication GetRibbonPanels )
Public method GetRibbonPanels(String)
(Overrides UIApplication GetRibbonPanels(String) )
Public method GetRibbonPanels(Tab)
(Overrides UIApplication GetRibbonPanels(Tab) )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Initialize For Revit Macros internal use only.
Public method LoadAddIn Loads add-ins from the given manifest file.
(Inherited from UIApplication )
Public method LoadPackageContents Loads add-ins from the given packageContents.xml file.
(Inherited from UIApplication )
Public method OnShutdownEO For Revit Macros internal use only.
Public method OpenAndActivateDocument(String) Opens and activates a Revit document.
(Inherited from UIApplication )
Public method OpenAndActivateDocument(ModelPath, OpenOptions, Boolean) Opens and activates a Revit document, include both local document or cloud document.
(Inherited from UIApplication )
Public method OpenAndActivateDocument(ModelPath, OpenOptions, Boolean, IOpenFromCloudCallback) Opens and activates a Revit document, include both local document or cloud document.
(Inherited from UIApplication )
Public method PostCommand Posts the command to the Revit message queue to be invoked when control returns from the current API context.
(Inherited from UIApplication )
Public method RegisterContextMenu Adds a new context menu creator.
(Inherited from UIApplication )
Public method RegisterDockablePane Adds a new dockable pane to the Revit user interface.
(Inherited from UIApplication )
Public method RemoveAddInCommandBinding Removes an AddInCommandBinding.
(Inherited from UIApplication )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Events
Name Description
Public event ApplicationClosing Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
(Inherited from UIApplication )
Public event Code example DialogBoxShowing Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
(Inherited from UIApplication )
Public event DisplayingOptionsDialog Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
(Inherited from UIApplication )
Public event DockableFrameFocusChanged Subscribe to this event to be notified when a Revit GenericDockableFrame has gained focus or lost focus in the Revit user interface. This event is called only for API-created GenericDockableFrames.
(Inherited from UIApplication )
Public event DockableFrameVisibilityChanged Subscribe to this event to be notified when a Revit GenericDockableFrame has been shown or hidden in the Revit user interface. This event is called only for API-created GenericDockableFrames.
(Inherited from UIApplication )
Public event FabricationPartBrowserChanged Subscribe to MEP Fabrication part browser changed event to be notified when MEP Fabrication part browser is updated.
(Inherited from UIApplication )
Public event FormulaEditing Subscribe to the FormulaEditing event to be notified when the edit formula button has been clicked.
(Inherited from UIApplication )
Public event Code example Idling Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
(Inherited from UIApplication )
Public event MacroUpdated MacroUpdated.
(Inherited from UIApplication )
Public event SelectionChanged Subscribe to the SelectionChanged event to be notified after the selection was changed.
(Inherited from UIApplication )
Public event ThemeChanged Subscribe to the ThemeChanged event to be notified after the theme was changed.
(Inherited from UIApplication )
Public event TransferredProjectStandards Subscribe to the TransferredProjectStandards event to be notified after the scope of a Transfer Project Standards operation has been finalized.
(Inherited from UIApplication )
Public event TransferringProjectStandards Subscribe to the TransferringProjectStandards event to be notified before the scope of an impending Transfer Project Standards operation has been finalized in the Transfer Project Standards dialog.
(Inherited from UIApplication )
Public event ViewActivated Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
(Inherited from UIApplication )
Public event ViewActivating Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
(Inherited from UIApplication )
Top
See Also