Application
|
For Revit Macros use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 26.0.4.0 (26.0.4.0)

The ApplicationEntryPoint type exposes the following members.

Name | Description | |
---|---|---|
![]() |
ApplicationEntryPoint | Initializes a new instance of the ApplicationEntryPoint class |

Name | Description | |
---|---|---|
![]() |
ActiveAddInId |
Get current active external application or external command id.
(Inherited from UIApplication ) |
![]() |
ActiveUIDocument |
Provides access to an object that represents the currently active project.
(Inherited from UIApplication ) |
![]() |
AddinFolder | The full path to the Revit Macros module. |
![]() |
Application |
Returns the database level Application represented by this UI level Application.
(Inherited from UIApplication ) |
![]() |
DrawingAreaExtents |
Get the rectangle that represents the screen pixel coordinates of drawing area.
(Inherited from UIApplication ) |
![]() |
IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from UIApplication ) |
![]() |
IsViewerModeActive |
Determines if Revit session is in Viewer mode.
(Inherited from UIApplication ) |
![]() |
LoadedApplications |
Returns an array of successfully loaded external applications.
(Inherited from UIApplication ) |
![]() |
MainWindowExtents |
Get the rectangle that represents the screen pixel coordinates of the Revit main window.
(Inherited from UIApplication ) |
![]() |
MainWindowHandle |
Get the handle of the Revit main window.
(Inherited from UIApplication ) |
![]() |
ProductIsRS |
Identifies if the current Revit product has an RS designation. Most add-ins will not need to use this information.
(Inherited from UIApplication ) |

Name | Description | |
---|---|---|
![]() |
CanPostCommand |
Identifies if the given command can be posted, using
PostCommand(RevitCommandId)
.
(Inherited from UIApplication ) |
![]() |
CreateAddInCommandBinding |
Creates a new AddInCommandBinding.
(Inherited from UIApplication ) |
![]() |
CreateRibbonPanel(String) |
(Overrides UIApplication CreateRibbonPanel(String) ) |
![]() |
CreateRibbonPanel(String, String) |
(Overrides UIApplication CreateRibbonPanel(String, String) ) |
![]() |
CreateRibbonPanel(Tab, String) |
(Overrides UIApplication CreateRibbonPanel(Tab, String) ) |
![]() |
CreateRibbonTab |
(Overrides UIApplication CreateRibbonTab(String) ) |
![]() |
Dispose |
(Inherited from UIApplication ) |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
FinishInitializationEO | For Revit Macros internal use only. |
![]() |
GetDockablePane |
Gets a DockablePane object by its ID.
(Inherited from UIApplication ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetRibbonPanels |
(Overrides UIApplication GetRibbonPanels ) |
![]() |
GetRibbonPanels(String) |
(Overrides UIApplication GetRibbonPanels(String) ) |
![]() |
GetRibbonPanels(Tab) |
(Overrides UIApplication GetRibbonPanels(Tab) ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
Initialize | For Revit Macros internal use only. |
![]() |
LoadAddIn |
Loads add-ins from the given manifest file.
(Inherited from UIApplication ) |
![]() |
LoadPackageContents |
Loads add-ins from the given packageContents.xml file.
(Inherited from UIApplication ) |
![]() |
OnShutdownEO | For Revit Macros internal use only. |
![]() |
OpenAndActivateDocument(String) |
Opens and activates a Revit document.
(Inherited from UIApplication ) |
![]() |
OpenAndActivateDocument(ModelPath, OpenOptions, Boolean) |
Opens and activates a Revit document, include both local document or cloud document.
(Inherited from UIApplication ) |
![]() |
OpenAndActivateDocument(ModelPath, OpenOptions, Boolean, IOpenFromCloudCallback) |
Opens and activates a Revit document, include both local document or cloud document.
(Inherited from UIApplication ) |
![]() |
PostCommand |
Posts the command to the Revit message queue to be invoked when control returns from the current API context.
(Inherited from UIApplication ) |
![]() |
RegisterContextMenu |
Adds a new context menu creator.
(Inherited from UIApplication ) |
![]() |
RegisterDockablePane |
Adds a new dockable pane to the Revit user interface.
(Inherited from UIApplication ) |
![]() |
RemoveAddInCommandBinding |
Removes an AddInCommandBinding.
(Inherited from UIApplication ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |

Name | Description | |
---|---|---|
![]() |
ApplicationClosing |
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
(Inherited from UIApplication ) |
![]() |
DialogBoxShowing |
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
(Inherited from UIApplication ) |
![]() |
DisplayingOptionsDialog |
Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
(Inherited from UIApplication ) |
![]() |
DockableFrameFocusChanged |
Subscribe to this event to be notified when a Revit GenericDockableFrame has gained focus or lost focus in the Revit user interface.
This event is called only for API-created GenericDockableFrames.
(Inherited from UIApplication ) |
![]() |
DockableFrameVisibilityChanged |
Subscribe to this event to be notified when a Revit GenericDockableFrame has been shown or hidden in the Revit user interface.
This event is called only for API-created GenericDockableFrames.
(Inherited from UIApplication ) |
![]() |
FabricationPartBrowserChanged |
Subscribe to MEP Fabrication part browser changed event to be notified when MEP Fabrication part browser is updated.
(Inherited from UIApplication ) |
![]() |
FormulaEditing |
Subscribe to the FormulaEditing event to be notified when the edit formula button has been clicked.
(Inherited from UIApplication ) |
![]() |
Idling |
Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
(Inherited from UIApplication ) |
![]() |
MacroUpdated |
MacroUpdated.
(Inherited from UIApplication ) |
![]() |
SelectionChanged |
Subscribe to the SelectionChanged event to be notified after the selection was changed.
(Inherited from UIApplication ) |
![]() |
ThemeChanged |
Subscribe to the ThemeChanged event to be notified after the theme was changed.
(Inherited from UIApplication ) |
![]() |
TransferredProjectStandards |
Subscribe to the TransferredProjectStandards event to be notified after the scope of a Transfer Project Standards operation has been finalized.
(Inherited from UIApplication ) |
![]() |
TransferringProjectStandards |
Subscribe to the TransferringProjectStandards event to be notified before the scope of an impending Transfer Project Standards operation has been finalized in the Transfer Project Standards dialog.
(Inherited from UIApplication ) |
![]() |
ViewActivated |
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
(Inherited from UIApplication ) |
![]() |
ViewActivating |
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
(Inherited from UIApplication ) |