Filtered |
Applies an ExclusionFilter to the collector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- idsToExclude ICollection ElementId
- The ids to exclude from the results.
Return Value
FilteredElementCollectorA handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Exception | Condition |
---|---|
ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration. |
ArgumentNullException | A non-optional argument was null |

Elements passed to this filter will be automatically excluded from the results. If you have an active iterator to this collector it will be stopped by this call.