Compound |
Verifies that the data in this layer is internally consistent.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- layerIdx Int32
- The index of the layer in the compound structure to be set.
- layer CompoundStructureLayer
- The layer to be set.
Return Value
BooleanTrue if the layer is internally consistent, false if the layer is not internally consistent.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

If the layer function is not Membrane or StructuralDeck, the width must be greater than zero. If the layer function is not StructuralDeck, then the deck embedding type must be Invalid, and the deck profile id must be InvalidElementId.