IsLayerValid Method


Compound Structure Is Layer Valid Method

Verifies that the data in this layer is internally consistent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool IsLayerValid(
	int layerIdx,
	CompoundStructureLayer layer
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
layer CompoundStructureLayer
The layer to be set.

Return Value

Boolean
True if the layer is internally consistent, false if the layer is not internally consistent.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If the layer function is not Membrane or StructuralDeck, the width must be greater than zero. If the layer function is not StructuralDeck, then the deck embedding type must be Invalid, and the deck profile id must be InvalidElementId. The priority must be valid to match the function. Refer to IsValidLayerPriority(Int32, Int32) .
See Also