FieldDomainPointsByUV Constructor (IList(UV), ICollection(Double), ICollection(Double))


Field Domain Points By UV(IList UV , ICollection Double , ICollection Double ) Constructor

Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FieldDomainPointsByUV(
	IList<UV> points,
	ICollection<double> uCoordinates,
	ICollection<double> vCoordinates
)

Parameters

points IList UV
Array of two-dimensional point coordinates representing domain points (usually on surface)
uCoordinates ICollection Double
Set of u coordinates at which to draw grid lines on the surface
vCoordinates ICollection Double
Set of v coordinates at which to draw grid lines on the surface
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also