AssemblyDifferenceMemberDifference Class


Assembly Difference Member Difference Class

The two assemblies being compared have different members
Inheritance Hierarchy
System Object
Autodesk.Revit.DB AssemblyDifference
Autodesk.Revit.DB AssemblyDifferenceMemberDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AssemblyDifferenceMemberDifference : AssemblyDifference

The AssemblyDifferenceMemberDifference type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AssemblyDifference )
Public property MemberDifference Difference between the assembly members
Public property MemberId1 Id of the member in the first assembly
Public property MemberId2 Id of the member in the second assembly
Top
Methods
Name Description
Public method Dispose
(Inherited from AssemblyDifference )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This difference means that there is a member of the first assembly which is different from the corresponding member of the second assembly. Details about the difference are in memberDifference.
See Also