Face |
Creates a new instance of a face toposolid attached to a non-vertical massing face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FaceToposolid Create(
Document document,
ElementId toposolidTypeId,
ElementId levelId,
IList<Reference> faceReferences
)
Parameters
- document Document
- The document.
- toposolidTypeId ElementId
- The toposolid type.
- levelId ElementId
- The level id.
- faceReferences IList Reference
- The references from the massing face.
Return Value
FaceToposolidThe newly created face toposolid.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- Toposolid type is not valid for this face toposolid. -or- The ElementId levelId is not a Level. -or- The faces are not valid for face toposolid creation. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |