ItemData Class


Item Data Class

Base class used to contain information necessary to construct RibbonItem and ContextMenuItem
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ItemData : IDisposable

The ItemData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The internal name of the item.
Public property ToolTip The tooltip of item.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ItemData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also