Item |
Base class used to contain information necessary to construct RibbonItem and ContextMenuItem

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The ItemData type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Name | The internal name of the item. |
![]() | ToolTip | The tooltip of item. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ItemData |