TriangulationInterfaceForTriangulatedShellComponent Class


Triangulation Interface For Triangulated Shell Component Class

This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TriangulationInterface
Autodesk.Revit.DB TriangulationInterfaceForTriangulatedShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TriangulationInterfaceForTriangulatedShellComponent : TriangulationInterface

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Constructors
Name Description
Public method TriangulationInterfaceForTriangulatedShellComponent Constructs an interface object for a TriangulatedShellComponent.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from TriangulationInterface )
Top
Methods
Name Description
Public method Dispose
(Inherited from TriangulationInterface )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Compare to TriangulationInterfaceForTriangulatedSolidOrShell, which treats with the entire solid or shell as a single triangulated structure.
See Also