TriangulationInterfaceForTriangulatedShellComponent Class


Triangulation Interface For Triangulated Shell Component Class

This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TriangulationInterface
Autodesk.Revit.DB TriangulationInterfaceForTriangulatedShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TriangulationInterfaceForTriangulatedShellComponent : TriangulationInterface

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Constructors
Name Description
Public method TriangulationInterfaceForTriangulatedShellComponent Constructs an interface object for a TriangulatedShellComponent.
Top
Properties
Name Description
Top
Methods
Name Description
Top
Remarks
Compare to TriangulationInterfaceForTriangulatedSolidOrShell, which treats with the entire solid or shell as a single triangulated structure.
See Also