Triangulation |
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.

System Object
Autodesk.Revit.DB TriangulationInterface
Autodesk.Revit.DB TriangulationInterfaceForTriangulatedShellComponent
Autodesk.Revit.DB TriangulationInterface
Autodesk.Revit.DB TriangulationInterfaceForTriangulatedShellComponent
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Name | Description | |
---|---|---|
![]() | TriangulationInterfaceForTriangulatedShellComponent | Constructs an interface object for a TriangulatedShellComponent. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

Compare to TriangulationInterfaceForTriangulatedSolidOrShell, which treats with the entire solid or shell as a single triangulated structure.