CommandMenuItem Class


Command Menu Item Class

A class representing a single command menu item.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI MenuItem
Autodesk.Revit.UI CommandMenuItem

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CommandMenuItem : MenuItem

The CommandMenuItem type exposes the following members.

Constructors
Name Description
Public method CommandMenuItem Initialize the item data.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MenuItem )
Top
Methods
Name Description
Public method Dispose
(Inherited from MenuItem )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetAvailabilityClassName Set availabilityClassName of CommandMenuItem
Public method SetToolTip Set toolTip of CommandMenuItem
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

To add a menu item that can be executed, implement IExternalCommand interface and pass external command class name to CommandMenuItem constructor, create the CommandMenuItem object and use AddItem() method to add the object to context menu.

See Also