Command |
A class representing a single command menu item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The CommandMenuItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | CommandMenuItem | Initialize the item data. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | SetAvailabilityClassName | Set availabilityClassName of CommandMenuItem |
![]() | SetToolTip | Set toolTip of CommandMenuItem |

To add a menu item that can be executed, implement IExternalCommand interface and pass external command class name to CommandMenuItem constructor, create the CommandMenuItem object and use AddItem() method to add the object to context menu.